La versión actual de OSPF para IPv4 es OSPFv2, introducida en RFC 1247 y actualizada en RFC 2328 por John Moy. En 1999, OSPFv3 para IPv6 se publicó en RFC 2740.
OSPF es un protocolo de routing de estado de enlace sin clase con una distancia administrativa predeterminada de 110 y se indica en la tabla de routing con el código de origen de ruta O.
OSPF se habilita con el comando router ospf id-proceso del modo de configuración global. El valor id-proceso tiene importancia en el ámbito local, lo que significa que no necesita coincidir con otros routers OSPF para establecer adyacencias con esos vecinos.
El comando network utilizado con OSPF cumple la misma función que cuando se lo utiliza con otros protocolos de routing IGP, pero con una sintaxis ligeramente diferente. El valor máscara-wildcard es el valor inverso a la máscara de subred, y el valor id-área se debe establecer en 0.
De manera predeterminada, los paquetes de saludo OSPF se envían cada 10 segundos en segmentos de accesos múltiples y punto a punto, y cada 30 segundos en los segmentos NBMA (Frame Relay, X.25, ATM), y OSPF los usa para establecer adyacencias de vecinos. De manera predeterminada, el intervalo muerto es equivalente a cuatro veces el valor del intervalo de saludo.
Para que los routers establezcan una adyacencia, sus intervalos de saludo, intervalos muertos, tipos de red y máscaras de subred deben coincidir. Use el comando show ip ospf neighbors para verificar las adyacencias OSPF.
En una red de accesos múltiples, OSPF elige un DR para que funcione como punto de recopilación y distribución de las LSA enviadas y recibidas. Un BDR se elige para cumplir la función del DR en caso de que este falle. Todos los demás routers se conocen como DROTHER. Todos los routers envían sus LSA al DR, que luego satura con la LSA todos los demás routers en la red de accesos múltiples.
El comando show ip protocols se utiliza para verificar la información importante de configuración OSPF, incluidas la ID del proceso OSPF, la ID del router y las redes que anuncia el router.
OSPFv3 se habilita en una interfaz, no en el modo de configuración del router. OSPFv3 necesita que se configuren direcciones link-local. Se debe habilitar el routing de unidifusión IPv6 para OSPFv3. Para habilitar una interfaz para OSPFv3, antes se requiere una ID de router de 32 bits.