Existen solamente dos protocolos de routing de estado de enlace: OSPF e IS-IS.
El protocolo OSPF (Open Shortest Path First) es la implementación más popular. Fue diseñado por el grupo de trabajo de OSPF del Grupo de trabajo de ingeniería de Internet (IETF). El desarrollo de OSPF comenzó en 1987 y actualmente hay dos versiones en uso:
- OSPFv2: OSPF para redes IPv4 (RFC 1247 y RFC 2328)
- OSPFv3: OSPF para redes IPv6 (RFC 2740)
Nota: con la característica de familias de direcciones de OSPFv3, esta versión del protocolo es compatible con IPv4 e IPv6.
El protocolo IS-IS fue diseñado por la Organización Internacional para la Estandarización (ISO) y se describe en ISO 10589. La primera versión de este protocolo de routing se desarrolló en la Digital Equipment Corporation (DEC) y se conoce como “DECnet fase V”. Radia Perlman fue la principal diseñadora del protocolo de routing IS-IS.
IS-IS se diseñó originalmente para el suite de protocolos de OSI y no para el suites de protocolo de TCP/IP. Más adelante, IS-IS integrado, o IS-IS doble, incluyó la compatibilidad con redes IP. Si bien se conoció a IS-IS como el protocolo de enrutamiento más utilizado por proveedores e ISP, se están comenzando a utilizar más redes IS-IS corporativas.
OSPF e IS-IS presentan varias similitudes y diferencias. Existen diversas posturas a favor de OSPF y a favor de IS-IS que analizan y debaten las ventajas de un protocolo de enrutamiento frente al otro. Ambos protocolos de routing proporcionan la funcionalidad de routing necesaria.